Vous n'êtes pas connecté.

 

#1 2006-12-10 11:39:48

dean
Besoin d'aide?
Lieu: Franche Comté
Date d'inscription: 2006-01-14
Messages: 1281
Site web

Installation V 1.0.5&1.0.6

Attention, dernier tuto pour la version 1.2 de zenphoto en français:
http://zenbien.com/infos/viewtopic.php?id=507

TUTORIEL

Installation de Zenphoto 1.0.5 & 1.0.6




Auteur : Kongasiou Dean
Mail :kongasiou@gmail.com
Date:10/12/2006
Maj:22/12/2006


Pré-requis :



  • •  Avoir un hébergement avec une base de donnée mysql active

  • •  Savoir transférer les fichiers sur le serveur

  • •  Avoir un éditeur de texte


  • Logiciels utilisés pour l'installation ( gratuits ) :



  • •  Editeur de texte Notepad ++ v3.4

  • •  Client Ftp pour le transfert des fichiers : Filezilla V2.2.18


  • Fichiers à télécharger et à décompresser :



    Version originale en Anglais
  • •  zenphoto 1.0.6.zip
  • 12/21/2006 nouveau

  • •  zenphoto 1.0.5.zip
  • 12/08/2006


    Fichier à supprimer


    .htaccess

    Fichier à éditer



    zen/zp-config.php.example ( puis à renommer en zp-config.php ), ne pas oublier zp- !

    Liens utiles:



  • •  Site officiel


  • Installation



    Editer le fichier zen/zp-config.php.example en mettant à jour les variables suivantes :

    ligne 22
    user = votre login de base de donnée ( login pour free, root par defaut avec easyphp )

    ligne 23
    pass = votre mot de passe de base de donnée ( mot de passe pour free, rien par defaut pour easyphp )

    ligne 24
    localhost = adresse du serveur mysql( ne pas changer pour free et easyphp, sinon ça peut être sql4, sql6, mysql4.6...cela dépend de votre hébergeur )

    ligne 25
    database_name = le nom de la base de donnée ( login pour free)

    ligne 28
    mysql_prefix = Préfixe pour la création de vos tables( pour éviter des conflits avec des précédentes installations de zenphoto, facultatif)
    ne pas toucher si prmière installation

    ligne 48
    true = mettre false

    ligne 51
    admin = Votre login pour l'administration du site

    ligne 54
    1234 = Votre mot de passe pour l'administration du site

    ligne 57
    admin_email = Votre adresse e-mail

    Capture:

    http://kongasiou.free.fr/2006121001.jpg



    Renommer le fichier zp-config.php.example par zp-config.php ( retirer .example )




    Transférer les fichiers sur le serveur ( avec filezilla ) sauf le fichier .htaccess ( sinon ça marche pas sur free )

    Capture:

    http://kongasiou.free.fr/2006121002.jpg

    Attention, ne pas changer le chmod sur free( attributs de fichiers ), ça ne sert à rien.



    Aller à l'adresse d'installation http://votresite.free.fr/zen/setup.php
    Si zenphoto est dans un sous répertoire http://votresite.free.fr/lerepertoire/zen/setup.php
    Saisissez votre login et mot de passe d'administration ( edité dans config.php ), puis cliquer sur login.

    http://kongasiou.free.fr/zp105.jpg



    Si la fenêtre suivante s'affiche, c'est que la connexion à la base a réussi ( sinon revoir config.php ), cliquer sur go pour créer les tables albums, images et coments:

    http://kongasiou.free.fr/zp106.jpg



    Vous pouvez maintenant aller dans la partie administration ( administrate ) pour ajouter des photos

    http://kongasiou.free.fr/zp107.jpg



    Vous voilà donc dans la page d'accueil d'administration

    http://kongasiou.free.fr/zp108.jpg

    Pour acceder à la zone d'administration, (aprés deconnexion)  il faut aller à l'adresse http://votresite.free.fr/zen/admin.php

    Bon, maintenant je vais tester les sous-albums...   


    Expert e-commerce sportif et très occuppé

    Hors ligne

     

    #2 2006-12-10 12:08:05

    dean
    Besoin d'aide?
    Lieu: Franche Comté
    Date d'inscription: 2006-01-14
    Messages: 1281
    Site web

    Re: Installation V 1.0.5&1.0.6

    Et bien... smile

    il vous faut éditer le thème pour la gestion des sous-albums...

    En voiçi un en téléchargemment (à mettre dans le dossier thème)
    testing-de

    http://kongasiou.free.fr/2006121004.jpg   

    Ensuite il faut activer ce thème dans le menu option

    http://kongasiou.free.fr/2006121003.jpg                       
                           
    Voilà

    Par ftp (avec filezilla), il suffit de créer des repertoires et mettre vos albums dans ce repertoire

    exemple albums/album/sousalbum1
                                      /sousalbum2

    http://kongasiou.free.fr/2006121005.jpg   

    Voilà ce que ça donne sur le thème de test   

    http://kongasiou.free.fr/2006121006.jpg

    http://kongasiou.free.fr/2006121007.jpg

    http://kongasiou.free.fr/2006121008.jpg

    Bon il n'est pas possible de gérer actuellement les sous-albums via l'adinistration du site.

    Tout se transfert via ftp
    Cette version a été rapidemment mise en ligne pour apaiser l'impatience des utilisateurs...


    Expert e-commerce sportif et très occuppé

    Hors ligne

     

    #3 2006-12-23 12:58:14

    kyungjin
    Invité

    Re: Installation V 1.0.5&1.0.6

    J'ai un problème agaçant.
    Sur un serveur free, qui comporte déjà une installation de dotclear.
    J'avais installé Zenphoto 1.0.3, puis suite au bug que je vais expliquer ensuite, j'ai désinstallé complètement Zenphoto, puis installé la version 1.0.5.

    Tout fonctionne bien pendant 4-5 jours, puis après je me retrouve avec des
    "Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request."
    à répétition quand je veux accéder à la galerie, et des lenteurs de chargement pour le blog sous dotclear. Avec la 1.0.3 j'avais aussi des erreur serveur en accédant au blog, pas avec la 1.0.5 pour l'instant.
    Les photos dans la galerie pèsent dans les 700 ko (grosse qalité pour que la famille puisse les récupérer et les imprimer).

    Si quelqu'un a une idée du souci...
    Merci

     

    #4 2006-12-23 13:45:57

    kyungjin
    Membre
    Date d'inscription: 2006-12-23
    Messages: 3
    Site web

    Re: Installation V 1.0.5&1.0.6

    Désolé, dans ma précipitation j'ai pas pris le temps de parcourir le forum, mon message aurait certainement plus sa place dans la section bugs+solutions.

    Sinon, j'ajoute que je viens d'avoir l'"internal server error" en essayant d'accéder au blog.

    La structure de mon site est
    Racine > le répertoire Dotclear et le épertoire  Zenphoto au même niveau.
    Il y a une protection par .htaccess dans le répertoire dotclear et une dans le répertoire Zenphoto.

    Hors ligne

     

    #5 2006-12-23 15:08:10

    dean
    Besoin d'aide?
    Lieu: Franche Comté
    Date d'inscription: 2006-01-14
    Messages: 1281
    Site web

    Re: Installation V 1.0.5&1.0.6

    Internal Server Error, c'est souvent dû à un problème venant du serveur (donc free), dans ces cas il faut attendre un peu.

    essais d'enlever les .htaccess pour voir ce que ça donne (avec le mode rewrite=false dans zp-config.php)


    Expert e-commerce sportif et très occuppé

    Hors ligne

     

    #6 2006-12-23 18:44:14

    kyungjin
    Membre
    Date d'inscription: 2006-12-23
    Messages: 3
    Site web

    Re: Installation V 1.0.5&1.0.6

    Merci pour la réponse.
    Ce que j'ai trouvé suspect, c'est que je  n'ai constaté ce problème que lorsque Zenphoto est installé.
    J'ai déjà essayé sans les .htaccess, ça ne change rien.
    Pour l'instant ça fonctionne...

    Y a-t'il des problèmes connus de conflit avec des installations multiples sur le même serveur (dans mon cas Dotclear + Zenphoto). A moins que ce ne soit Free qui soit capricieux à ce niveau là?

    Hors ligne

     

    #7 2006-12-23 22:55:21

    dean
    Besoin d'aide?
    Lieu: Franche Comté
    Date d'inscription: 2006-01-14
    Messages: 1281
    Site web

    Re: Installation V 1.0.5&1.0.6

    le htaccess de dotclear peut être la cause de ton problème, je n'ai pas installé dotclear, je ferais un test de compatibilité.


    Expert e-commerce sportif et très occuppé

    Hors ligne

     

    #8 2006-12-29 08:01:31

    patoun
    Membre
    Date d'inscription: 2006-12-29
    Messages: 3

    Re: Installation V 1.0.5&1.0.6

    J'ai un problème que je ne saisis pas. Installé propre WordPress et Zenphoto 1.06 (je fais mes premiers pas et je test celà en local sur mon pc), chacun fonctionne bien, j'ai mis zen.php dans les plugins et activé dans WP et ZenPhoto à des albums qui fonctionne en autonome.

    Par contre dans WP, quand j'ajoute la balise dans WP, il voit bien 5 images mais par contre remplace les images par des croix rouges et ne trouve pas les images... et si on va sur une image... j'ai une erreur 404...

    Hors ligne

     

    #9 2006-12-29 15:14:34

    patoun
    Membre
    Date d'inscription: 2006-12-29
    Messages: 3

    Re: Installation V 1.0.5&1.0.6

    J'aii trouvé..... j'ai du mettre un nouvel alias    dans EasyPHP pour Zenimage en plus du nom du blog de WP..... étrange

    Hors ligne

     

    #10 2006-12-31 11:06:36

    bzh33
    Invité

    Re: Installation V 1.0.5&1.0.6

    Salut
    Juste une question sur la procédure de modif, est-ce dire que les fichiers functions.php et admin-functions.php ne doivent plus être modifiés (comme ct le cas pour la version 1.0.1) ?

     

    #11 2007-01-08 13:38:58

    dean
    Besoin d'aide?
    Lieu: Franche Comté
    Date d'inscription: 2006-01-14
    Messages: 1281
    Site web

    Re: Installation V 1.0.5&1.0.6

    salut
    Exact ces fichiers ne sont plus à modifier dans les dernières versions de zenphoto


    Expert e-commerce sportif et très occuppé

    Hors ligne

     

    #12 2007-02-27 23:33:13

    dean
    Besoin d'aide?
    Lieu: Franche Comté
    Date d'inscription: 2006-01-14
    Messages: 1281
    Site web

    Re: Installation V 1.0.5&1.0.6

    Veuillez installer la dernière version de zenphoto 1.0.7b

    Il ne devrait pas y avoir de différence au niveau de l'installation, suivre le tuto dessus.

    http://www.zenphoto.org/files/zenphoto-1.0.7.zip

    Dean


    Expert e-commerce sportif et très occuppé

    Hors ligne

     

    #13 2007-04-17 22:33:33

    regain
    Membre
    Date d'inscription: 2007-04-17
    Messages: 1

    Re: Installation V 1.0.5&1.0.6

    Bonjour,

    J'ai fait la mise à jour de Zenphoto 1.0.7 vers la 1.0.8.2 sur free.fr et à l'issue de l'installation, l'erreur suivante s'est produite dans l'interface d'administration :

    Warning: session_start() [function.session-start]: open(/mnt/112/sdb/f/7/gocc.guerin/sessions/sess_9d32f548823cd6f3894ab0252d0dc9a2, O_RDWR) failed: No such file or directory (2) in /mnt/112/sdb/f/7/gocc.guerin/zenphoto/zen/admin.php on line 2

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mnt/112/sdb/f/7/gocc.guerin/zenphoto/zen/admin.php:2) in /mnt/112/sdb/f/7/gocc.guerin/zenphoto/zen/admin.php on line 2

    Après des recherches sur Internet, je suis finalement tombé sur cette piste :
    http://forum.pluxml.org/viewtopic.php?pid=1294

    Il faut créer un répertoire "sessions" à la racine de notre domaine free.fr

    HTH, regain

    Hors ligne

     

    Pied de page du Forum

    Forum PunBB